Kenwood KDC-BT752HD Bluetooth Through the Front Speakers Only?

Kenwood KDC-BT752HD

Kenwood KDC-BT752HD

A while back I installed a Kenwood KDC-BT752HD in one of my cars to replace the lame unit that came from the factory.  The main feature I wanted was BT audio (A2DP streaming), Pandora functionality and HD radio were bonuses.  I use the Pandora functions much more than I expected I would.

Anyway, as a cheap unit it did it’s job just fine except that the Bluetooth audio only played out of the front speakers.  I upgraded the firmware, but that didn’t help.

It turns out that BT through the front speakers is the default setting in the BT configuration menu.  Why that’s the default, I can’t imagine.

To change it to all speakers:

  1. Turn on the unit
  2. Press the Phone icon to enter Bluetooth mode
  3. Turn the Volume knob to “Settings” and press Volume
  4. Turn the Volume knob to “Detailed Set” and press Volume
  5. Turn the Volume knob to “Settings” and press Volume
  6. Turn the Volume knob to “BT HF/AUDIO” and press Volume
  7. Turn the Volume knob to “All” and press Volume
  8. Press the back arrow repeatedly until you back out of the menu

Next time you play Bluetooth audio you should have all speakers works.

You can see pages 22-24 in the radio’s manual for more details.

 

This entry was posted in Car Stuff. Bookmark the permalink.

16 Responses to Kenwood KDC-BT752HD Bluetooth Through the Front Speakers Only?

  1. SK says:

    Thank you so much for this I formation, almost identical for Samsung Galaxy TabPro. What I can’t understand (unless I missed it) is why doesn’t Kenwood include this information in the user’s manual??
    Much appreciated and now I have 2X the quality experience!

    Steve

  2. Adam says:

    Thanks! Exactly my issue on a Kenwood KMR-D558BT boat radio. Crazy to have front as the default, come on Kenwood!

  3. Tyler says:

    Man thx a bunch my dpx 500bt in my airstream had same thing bedroom speakers didn’t work.

  4. Jose says:

    Thanks this was extremely useful. It was driving me crazy for a while.thanks again

  5. EJ says:

    Dude! Thanks for the info! Came up in one of the first couple of searches. Saved me from junking this radio. 🙂

  6. Houseparty says:

    Thanks for the info. All speakers are working now but the fader doesn’t actually work still. However all speakers working the same is better than no back ones 😉

  7. Laurie says:

    This write up is exactly what I was looking for – thank you!!!!

  8. Mike says:

    That was driving me nuts, only the front speakers, thanks. Sounds a lot better.

  9. Brett says:

    I hooked up my Kenwood KDC BT555U to my golf cart. It will connect to my android phone and I can see the music playing across the screen. However, I can’t get any sound from the speakers. It only has two speakers connected to the stereo. Help please!

    • Jerry says:

      Try the post above, or switch speaker wires. I have also noticed that some units must have the antenna hooked up. I’m thinking the antenna hookup is ground for the speakers.

  10. chai says:

    This is exactly what I was looking for – thank you!!

  11. Kahana says:

    Thank the lord for your post. I went amost 3 years thinking my Bluetooth was broken. Wasn’t until today my friend told me to google it and sure enough, the answer was right here. Thanks again!

  12. George OBrien says:

    Ditto for the KDC BT955HD. I had to reset the unit because it was malfunctioning and the back speakers didn’t work on BT Audio; I remember the installer having to set it up but not what he did. Thank you!

    PS – a great unit, top of the line in 2013, I got it for $50 at BB as an open box, had to buy all of the cables and buttons for not very much and got a great headunit. I wouldn’t be able to spring for the $200 to replace it today.

  13. Thank you! Mine was slightly different because it’s a different model (KDC-X598), but since I knew (from your article) to look for “HF,” it made it WAY easier. Been trying to figure it out for months! Thanks again.

  14. Michael D says:

    Thank you so much…same exact issue, same radio. Had it completely unassembled and tracing each line. Was stuck until I read this. Thank you!

  15. Joe N says:

    Thanks so much, I was ready to trash the stereo! Very helpful!

Leave a Reply

Your email address will not be published. Required fields are marked *